Основные возможности

Автосекретарь SpRecord - это программный комплекс, предназначенный для составления голосового меню и его последующего выполнения на телефонной линии с использованием устройств SpRecord.

Автосекретарь позволяет:

  • круглосуточно обрабатывать входящие звонки
  • соединять абонента с сотрудником или отделом, минуя оператора
  • контролировать вызов внутреннего номера (различает результат соединения: занято, не отвечает или вызываемый абонент взял трубку)
  • работать с голосовой почтой
  • обрабатывать входящие звонки, поступающие в нерабочее время
  • организовать справочную службу (автоинформатор)

Отличительные характеристики Автосекретаря:

  • составление голосового меню любой сложности (нет ограничений на количество меню и их вложенность)
  • графическое представление алгоритма голосового меню (наподобие блок-схем)
  • одновременное выполнение нескольких голосовых меню на телефонных каналах
  • работа с голосовой почтой через телефон или компьютер
  • неограниченный размер почтового ящика
  • многопользовательский интерфейс с разграничением прав доступа
  • получение отчетов (статистики) о работе Автосекретаря
  • встроенный звуковой редактор, позволяющий быстро составлять звуковые фразы

Автосекретарь SpRecord может работать только с устройствами SpRecord модели AT.

Смотрите также:

Состав программного комплекса


Состав программного комплекса

«Автосекретарь» состоит из следующих модулей:

  • Сервер
  • Клиент
  • Звуковой Редактор

Сервер «Автосекретаря» является центральным модулем в комплексе. Он выполняет на телефонных каналах алгоритмы голосового меню, используя программные и аппаратные возможности устройств SpRecord, взаимодействует с базами данных и следит за выполнением различных запросов от клиентов в рамках тех прав, которые им назначены. Сервер является службой, которая запускается при загрузке компьютера. Он должен быть установлен на компьютер, к которому подключены устройства SpRecord типа АТ.

Клиент представляет собой приложение Windows, в котором пользователь может создавать алгоритмы голосовых меню, запускать их на телефонных каналах, выполнять администрирование пользователей, прослушивать голосовые сообщения, управлять настройками сервера, создавать отчеты и др. Его можно установить на те компьютеры, на которых предполагается работа пользователей с «Автосекретарем».

Звуковой редактор используется для составления голосовых фраз, которые впоследствии можно применять в алгоритмах голосового меню. Он устанавливается вместе с клиентом.

Смотрите также:


Информация о производителе

Программный комплекс Автосекретарь SpRecord изготовлен ОOO "Сарапульские системы".

Почтовый адрес: 427960, Россия, Удмуртская Республика, г. Сарапул, а/я 91
Телефон/факс: +7 (34147) 2-56-92, 3-72-82
E-mail: info@sprecord.ru
Web-сайт: http://www.sprecord.ru

Технические вопросы
Поваренкин Александр
Телефон: +7 (34147) 2-56-92, 3-72-82
E-mail: sann-x@sprecord.ru

Общие вопросы и сотрудничество
Телефон/факс: +7 (34147) 2-56-92, 3-72-82
E-mail: zakaz@sprecord.ru

Смотрите также:

Основные возможности


Настройка устройства SpRecord

Перед использованием Автосекретаря необходимо настроить устройства SpRecord, чтобы открыть доступ к телефонным каналам.

Выполните следующие действия:

  1. Запустите программу SpRecord (она, как правило, находится в меню «Пуск/Программы/SpRecord 3/SpRecord 3.xx»)
  2. В меню «Настройки» выберите пункт «Параметры»

  3. Выберите закладку «Общее/Программа», установите галочку в пункте «Разрешить подключение библиотеки оповещения»

  4. Выберите закладку с устройством и каналом, на котором будет работать Автосекретарь, нажмите кнопку «Дополнительно»

  5. В закладке «Библиотека» установите галочку «Разрешить подключение к этому каналу через библиотеку SpRecord»

  6. Нажмите «ОК» в окнах «Дополнительные настройки» и «Настройки»

После успешной настройки устройства и каналов можно устанавливать и использовать программный комплекс Автосекретарь SpRecord.

Смотрите также:

Список каналов


Клиент «Автосекретаря SpRecord»

Клиент «Автосекретаря SpRecord» - это программа, с помощью которой выполняются различные задачи системы, например: составление голосового меню (алгоритма программы-автосекретаря), запуск алгоритма на телефонном канале, работа с голосовой почтой, администрирование пользователей и др.

Окно клиента состоит из нескольких рабочих областей:

1) Меню:
  • «Система»
    • «Авторизация» - повторно войти в систему.
    • «Выход» - завершить работу клиента.
  • «Инструменты» - открыть Звуковой редактор.
  • «Справка»
    • «Справка» - открыть справку Автосекретаря.
    • «О программе» - узнать текущуюю версию программы.
2) Панель инструментов содержит набор функциональных кнопок. Набор этих кнопок и выполняемые ими функции зависят от выбранной задачи.
3) Панель задач. В ней отображаются задачи, список которых зависит от имеющихся у пользователя прав. В контекстном меню этой области пользователь может обновить содержимое панели задач.
4) Задачи. В этой области отображается содержимое выбранной задачи, например список, алгоритм голосового меню и др.
5) Контекстное меню текущей задачи. Оно вызывается нажатием правой кнопки мыши. Содержимое контекстного меню зависит от выбранной задачи.

В клиенте доступны следующие задачи:


Вход в систему (авторизация)

Для того чтобы начать работу с «Автосекретарем», необходимо войти в систему (авторизоваться). После запуска клиента появляется окно входа в систему. Если запуск был первым после установки «Автосекретаря», то окно входа будет иметь расширенный вид.

При последующих запусках окно входа отображается в сжатом виде.

В полях логина и пароля необходимо ввести логин пользователя, зарегистрированного в системе, и его пароль. После установки «Автосекретаря» в системе заведены два пользователя: «ADMIN» (пароль «ADMIN») и «USER» (пароль «USER»).

Если клиент «Автосекретаря» находится на том же компьютере, на котором установлен сервер, то необходимо в настройках соединения отметить пункт «Сервер на этом компьютере». Для того чтобы установить связь с сервером, находящимся на другом компьютере, необходимо выбрать пункт «Сервер находится в сети» и нажать кнопку «Обзор». Далее в открывшемся окне нужно выбрать компьютер, на котором расположен сервер «Автосекретаря».

Номер порта1, через который сервер и клиент будут обмениваться информацией, указывается в поле «Порт».

Чтобы проверить соединение с сервером, необходимо нажать на кнопку «Тест».

Кнопка «Соединение» расширяет или сжимает окно входа в систему.

После успешной авторизации программа запоминает логин, пароль (если была выбрана соответствующая опция), адрес сервера и номер порта.

Смотрите также:

Администрирование пользователей
Сервер

Прим. 1. Если на компьютере сервера или клиента работает брандмауэр (фаервол), то его необходимо настроить так, чтобы сервер и клиент могли беспрепятственно обмениваться информацией по TCP/IP протоколу. В случае установки сервера инсталятор автоматически выполняет необходимые настройки брандмауэра Windows.


Список каналов

В задаче «Список каналов» отображаются все каналы устройств SpRecord, подключенных к компьютеру, на котором находится сервер «Автосекретаря». Эта задача позволяет управлять каналами устройств: назначать, запускать, останавливать и планировать выполнение программ.

Для того чтобы каналы устройств, подключенных к серверу, были доступны в программе «Автосекретарь», необходимо настроить устройства SpRecord и разрешить подключение к ним через библиотеку.

По умолчанию в списке каналов отображаются только те устройства, которые подключены к серверу. Отображение каналов отключенных устройств включается/выключается нажатием на панели инструментов кнопки [image].

Каналы устройства могут иметь следующие статусы:

1. При определении статуса произошла ошибка. Такое состояние могут иметь каналы, к которым запрещено подключение через библиотеку SpRecord.

2. К каналу устройства не подключена телефонная линия.

3. Телефонная линия подключена, трубка находится на аппарате.

4. Телефонная линия подключена, трубка поднята.

Обновление списка устройств и каналов происходит автоматически при изменении состояния или их подключении/отключении к компьютеру. Для принудительного обновления списка используется кнопка «Обновить» [image] на панели инструментов или соответствующий пункт в контекстном меню.


Выполнение программ на каналах

Запуск программы на канале выполняется следующим образом:

  • выберите канал в списке
  • установите на канале программу, которую необходимо выполнить:
    • для этого на панели инструментов нажмите кнопку «Связать канал с программой» [image] или в контекстном меню списка каналов выберите пункт «Связать с программой»
    • в появившемся окне выберите программу и нажмите «ОК». Если выбрать «[--нет--]», то канал не будет связан ни с одной программой.

  • на панели инструментов нажмите кнопку «Запустить программу на канале» [image] или в контекстном меню списка каналов выберите пункт «Запустить программу».

После успешного запуска выполняемый канал будет показан жирным шрифтом и в столбце списка «Автосекретарь работает» будет отображаться «Да».

Чтобы остановить выполняющуюся программу, необходимо на панели инструментов нажать кнопку «Остановить выполнение программы» [image] или в контекстном меню выбрать пункт «Остановить выполнение программы». После успешной остановки программы выполняемый канал будет показан обычным шрифтом и в столбце списка «Автосекретарь работает» будет отображаться «Нет».


Планировщик запуска

«Автосекретарь» имеет широкие возможности по планированию запуска программ на каналах. Вызов настройки планирования выполняется нажатием на панели инструментов кнопки «Настройка запуска» [image] или через контекстное меню выбором пункта «Планировщик».

Возможны 4 типа запуска программы на канале:

  1. «Планирование по дням недели». Этот тип позволяет запускать и завершать программу по дням недели в определенное время. Например, можно задать, чтобы «Автосекретарь» запускал программу по выходным, или в будние дни после окончания работы и т. п. Время между началом и концом выполнения программы должно составлять более двух минут.
  2. «Планировать по дате (датам)». Этот тип позволяет выполнять программу на канале в течение определенного периода. Начало и конец периода можно задать по дате или по дате и времени. Разница между началом и концом должна быть более двух минут.
  3. «Запуск после загрузки компьютера». Если задать этот тип планирования, то программа запустится сразу после включения или перезагрузки компьютера, на котором установлен сервер «Автосекретаря». Программа на канале запустится даже в том случае, если при загрузке компьютера операционная система ожидает выбора пользователя и/или ввода пароля для входа.
  4. «Ручное управление». В этом случае пользователь системы сам следит за запуском и остановкой программы, используя функции панели инструментов и контекстного меню.

Независимо от типа запуска программы пользователь может запускать/останавливать программы вручную, используя соответствующие функции панели инструментов и контекстного меню.


Администрирование пользователей

Программа «Автосекретарь» является многопользовательской системой с разграничением прав доступа к ее различным задачам. Такая организация программы позволяет свести к минимуму ошибки, возникающие по вине пользователей, и увеличивает стабильность ее работы.

«Автосекретарь» предоставляет доступ только зарегистрированным активным пользователям. Как правило, ведение пользователей осуществляется администратором системы.

Каждый пользователь в системе имеет определенную роль, которая, в свою очередь, ассоциирована с некоторым набором прав, определяющих, что может, а что не может выполнять в системе пользователь с данной ролью. Принцип разграничения прав доступа пользователей с использованием ролей графически представлен на рисунке:

Пользователи «П1» и «П2» имеют общую роль «1» (а значит и одинаковые права), которая связана с некоторым набором прав «А». Аналогично для пользователей «П3» и «П4». Роль «3» присвоена только одному пользователю «П5».

Практически в «Автосекретаре» можно завести две роли: «Администратор» и «Пользователи». Первая роль имеет максимальные права и предназначена для настройки и администрирования всей системы, а вторая – минимальные, ее можно присвоить рядовым пользователям, которые смогут просматривать и изменять собственные настройки и прослушивать личную голосовую почту.


Список пользователей

В этой задаче администратор системы может создавать и удалять пользователей, а также изменять их настройки (свойства). По умолчанию после установки программы «Автосекретарь» в системе заведено два пользователя: «ADMIN» (максимальные права) и «USER» (минимальные права).

Добавление и изменение свойств пользователей выполняется через панель инструментов или контекстное меню задачи: кнопка «Добавить пользователя» [image] и кнопка «Свойства пользователя» [image] соответственно.

При добавлении пользователя в свойствах необходимо указать следующее: логин и пароль для входа в систему, максимальную длину одного голосового сообщения, номер и пароль ящика голосовой почты, роль и активность. Остальные поля не обязательны для заполнения. Логин пользователя и номер ящика голосовой почты должны быть уникальны в рамках системы «Автосекретаря». Проверка на уникальность номера ящика выполняется нажатием на кнопку

При изменении свойств администратор не может изменять только логин пользователя.

Пользователь, имеющий доступ только к личным настройкам, может изменять из обязательных полей только пароль для входа в систему и пароль к личному ящику голосовой почты.

Операция удаления выполняется через панель инструментов или контекстное меню «Удалить пользователя» [image]. Удаление пользователей возможно только в случае, если они отмечены как неактивные и не имеют сообщений голосовой почты.

Обновление списка пользователей выполняется на панели инструментов нажатием на кнопку «Обновить» [image] или через контекстное меню задачи.

Удалять или изменять роль и активность пользователя «ADMIN» запрещено.


Роли

В этой задаче администратор может создавать, удалять роли и назначать права. Чтобы добавить роль, нужно на панели инструментов нажать на кнопку «Добавить роль» [image] или выбрать соответствующий пункт в контекстном меню. При добавлении программа запросит имя новой роли.

Чтобы удалить роль, нужно на панели инструментов нажать на кнопку «Удалить роль» [image] или выбрать соответствующий пункт в контекстном меню.

Удалить роль можно, только если она не связана с пользователями.

Назначить права можно через панель инструментов (кнопка «Назначить права на роль» [image]) или контекстное меню задачи.

В верхнем списке окна «Права роли» отображаются права, которые будут присвоены редактируемой роли, в нижнем – доступные права.

Перед перемещением прав из одного списка в другой необходимо сначала их выделить. Выделить можно один элемент или группу. Чтобы выделить в списке группу прав, необходимо, удерживая на клавиатуре кнопку «SHIFT», указать мышкой первый и последний элемент группы. Если необходимо выделить несколько прав, то, удерживая на клавиатуре кнопку «CTRL», выделите нужные элементы списка.

Чтобы переместить права из нижнего списка в верхний, необходимо нажать на кнопку «Добавить». Нажатие на кнопку «Добавить все» переместит все доступные права в верхний список. Удаление прав из верхнего списка осуществляется нажатием на кнопку «Убрать». Нажатие на кнопку «Убрать все» удалит все выбранные права.

После того как в верхнем списке будет сформирован желаемый набор прав, необходимо нажать на кнопку «ОК». Если нажать на кнопку «Отмена», то сделанные изменения не будут приняты.

В системе запрещено удалять или изменять роль «Все права».


Права

Список прав и их описание приведены в таблице.

Право | Описание
Список каналов: просмотр | Пользователь может просматривать список каналов
Список каналов: редактирование | Пользователь может назначать программу (алгоритм) на канал, планировать запуск программы (алгоритма)
Пользователи, список пользователей: просмотр | Пользователь может просматривать список пользователей, зарегистриро-ванных в системе
Пользователи, список пользователей: редактирование | Пользователь может изменять свойства всех пользователей, добавлять новых и удалять существующих пользователей
Пользователи, список пользователей: редактирование собственной учетной записи | Пользователь может просматривать и изменять только личные настройки
Пользователи, роли: просмотр | Пользователь может просматривать список ролей
Пользователи, роли: редактирование | Пользователь может добавлять и удалять роли, но не может назначать права (см. право «Роли и права: редактирование»)
Роли и права: просмотр | Пользователь может получать от сервера список всех прав и список прав, установленных на определенную роль (необходима для задачи «Роли», функция «Назначить права»)
Программы: просмотр | Пользователь может просматривать список программ и подпрограмм, а также содержимое дерева меню и алгоритма в Конструкторе
Программы: редактирование | Пользователь может изменять, добавлять и удалять программы и подпрограммы, а также сохранять содержимое дерева меню и алгоритм Конструктора в базе данных
Сервер: настройка | Пользователь имеет полный доступ к задаче «Сервер»
Журнал событий: просмотр событий | Пользователь может просматривать журнал событий
Список каналов: запуск, остановка, завершение автосекретаря | Пользователь может запускать и останавливать алгоритм (программу- автосекретарь) на телефонном канале
Голосовая почта: доступ к почте всех пользователей | Пользователь может удалять, прослушивать и просматривать список голосовых сообщений всех пользователей
Голосовая почта: доступ к почте только для своей учетной записи | Пользователь может удалять, прослушивать и просматривать список только личных голосовых сообщений
Роли и права: редактирование | Пользователь может назначать права на роль
Отчеты: формирование | Пользователь имеет полный доступ к задаче «Отчеты»

При назначении прав важно учитывать, что право на редактирование также дает право на просмотр.


Программы

Основная функция программного комплекса «Автосекретарь SpRecord» – выполнять на телефонном канале заранее подготовленный алгоритм (программу-автосекретарь). Составление и разработка таких алгоритмов выполняется в задаче «Программы».

Эта задача состоит из трех взаимосвязанных разделов:

  • Список, содержащий перечень имеющихся в системе программ и подпрограмм;
  • Дерево меню, позволяющее быстро и легко составлять голосовое меню любой сложности;
  • Конструктор, представляющий собой инструмент для составления алгоритма в наглядном графическом виде (наподобие блок-схемы).


Список программ и подпрограмм

В этом разделе отображается список программ и подпрограмм,сохраненных в базе данных «Автосекретаря».

Программы
Алгоритм, созданный с помощью Дерева меню или Конструктора, не может существовать в системе «сам по себе». Он всегда содержится в какой-либо программе. Список программ находится во вкладке «Программы».

Удаление программы производится нажатием на панели инструментов кнопки «Удалить программу» [image] или через контекстное меню (пункт «Удалить»). Программа будет удалена из системы, если она не связана ни с одним каналом.

Изменение свойств программы выполняется нажатием на панели инструментов кнопки «Свойства программы» [image] или через контекстное меню (пункт «Свойства»). Установка настройки «Монопольный доступ» запретит другим программам доступ к каналу во время выполнения программы-автосекретаря.

Обновление списка вызывается нажатием кнопки «Обновить» [image] или выбором соответствующего пункта в контекстном меню.

Подпрограммы
При формировании голосового меню с помощью дерева пользователь может встраивать в общий алгоритм свою подпрограмму (одну или несколько, один или более раз). Благодаря такой возможности Дерево меню является гибким инструментом разработки алгоритма программы-автосекретаря.

Ведение списка подпрограмм в основном не отличается от ведения списка программ. Одно отличие состоит в том, что среди свойств подпрограммы нет настройки «Монопольный доступ».


Дерево меню

Раздел «Дерево меню» - это гибкий инструмент, позволяющий быстро и легко создавать алгоритмы голосового меню. Этот раздел имеет дружественный и наглядный интерфейс, благодаря чему даже неподготовленный пользователь сможет создать голосовое меню.

Дерево меню имеет несколько рабочих областей. В первой области отображается иерархия меню в древовидной форме. Во второй области содержится описание меню, выбранное в области дерева.

Вставить какое-либо меню в дерево можно двумя способами: используя панель инструментов или контекстное меню дерева. В первом случае необходимо левой кнопкой мыши указать в дереве то меню, в которое будет вставляться новое, и затем на панели инструментов нажать кнопку, соответствующую нужному типу меню: общее меню [image], меню «Голосовая почта – Запись» [image] или меню «Голосовая почта – Прослушать» [image].

Во втором случае необходимо правой кнопкой мыши указать в дереве то меню, в которое необходимо вставить новое, в появившемся контекстном меню выбрать пункт «Добавить меню», затем пункт, соответствующий нужному типу меню: «Общее меню», «Голосовая почта – Запись» или «Голосовая почта – Прослушать».

Удаление меню производится подобным образом: через панель инструментов или контекстное меню. Сначала нужно в дереве указать удаляемое меню, а затем на панели инструментов нажать кнопку «Удалить меню» [image] или в контекстном меню выбрать пункт «Удалить».

Во время составления голосового меню «Автосекретарь» запоминает сделанные изменения. Используя меню клиента или панель инструментов, можно отменить или вернуть эти изменения.

Сохранение разрабатываемого голосового меню выполняется нажатием на панели инструментов кнопки «Сохранить дерево меню в базе данных» [image]. Причем в базе данных сохраняется только само дерево меню, без алгоритма. В окне сохранения необходимо выбрать существующую программу или ввести имя новой:

Чтобы загрузить из базы данных дерево меню, нужно нажать на панели инструментов кнопку «Загрузить дерево меню из базы данных» [image]. Алгоритм, даже если он сохранен в программе, не загружается. Программа, из которой будет загружаться дерево меню, указывается в окне загрузки:

При составлении голосового меню можно периодически проверять его на наличие ошибок, нажимая кнопку «Проверить дерево меню на ошибки» [image].

Удаление существующего голосового меню выполняется кнопкой «Создать новое дерево меню» [image]. Данные, находящиеся в БД, не изменяются.

После того как голосовое меню полностью разработано, его необходимо преобразовать в алгоритм (скомпилировать). Эта операция выполняется нажатием на панели инструментов кнопки «Скомпилировать и сохранить алгоритм» [image]. Перед компиляцией «Автосекретарь» запросит имя программы, в которую будет сохранены дерево меню и алгоритм.

При компиляции «Автосекретарь» выполняет следующие действия:

  • проверка дерева меню на ошибки;
  • сохранение дерева меню в базе данных;
  • непосредственно компиляция;
  • проверка полученного алгоритма на ошибки;
  • сохранение алгоритма в базе данных.

Ход компиляции разработанного голосового меню отображается в отдельном окне:

Если во время компиляции обнаружится ошибка, то программа прервет компиляцию и выдаст поясняющее сообщение об ошибке.

После успешной компиляции преобразованное в алгоритм голосовое меню также отображается в Конструкторе. В Конструкторе пользователь может внести желаемые корректировки в алгоритм, а потом сохранить его в базе дынных. Успешно сохраненный алгоритм сервер «Автосекретаря» может выполнять на телефонном канале.


Типы голосового меню

В Дереве меню существует шесть типов меню:

  • Главное меню
  • Общее меню
  • Меню «Голосовая почта – Запись»
  • Меню «Голосовая почта – Прослушать» уровень 1
  • Меню «Голосовая почта – Прослушать» уровень 2
  • Меню «Голосовая почта – Прослушать» уровень 3


Главное меню

В иерархии дерева главное меню находится на самом верхнем уровне, а все остальные меню расположены на втором и более низком уровне. Только в главном меню есть настройка, в которой определяется число гудков срабатывания программы-автосекретаря. Меню этого типа в алгоритме программы-автосекретаря встречается один раз.

В упрощенном виде ход выполнения алгоритма главного меню выглядит следующим образом:

  1. Ожидать входящий звонок. После N гудка автосекретарь сработает и снимет трубку.
  2. Произнести в телефонную линию звуковые данные.
  3. Ожидать ввод абонента.
  4. Выполнить действие (набрать номер, перейти в меню и др.) в зависимости от того, что ввел абонент.

Главное меню состоит из четырех пунктов.

В пункте №1 пользователь указывает, после какого гудка при входящем звонке программа-автосекретарь должна сработать и поднять трубку. Если количество гудков будет равно одному или нолю, то автосекретарь сработает при первом гудке.

В пункте №2 пользователь указывает, какой аудиофайл нужно проиграть в телефонную линию. Аудиофайл можно указать, введя его имя (и путь к нему, если нужно) в поле ввода, либо нажав на кнопки «Выбрать» или «Звуковой редактор». Кнопка «Выбрать» откроет окно, в котором пользователю нужно будет указать звуковой файл, находящийся на диске компьютера (формат PCM, расширение WAV, моно, 8 бит, 11025 кГц). Нажатие кнопки «Звуковой редактор» откроет программу, в которой пользователь сможет создать голосовую фразу, используя микрофон, и отредактировать ее. При сохранении созданной фразы в Звуковом редакторе через меню «Файл\Сохранить как...» имя файла автоматически будет скопировано в поле ввода.

В пункте №3 пользователь указывает, какой тип ввода использовать. Тип ввода «количество символов» означает, что автосекретарь будет ждать, когда абонент введет нужное количество символов на телефоне. После того как абонент введет указанное в настройках количество символов, программа-автосекретарь перейдет к пункту №4. Тип ввода «до завершающего символа» означает, что автосекретарь будет ожидать, пока абонент не нажмет завершающий символ (выбирается из всплывающего списка). Если абонент за время ожидания ввода («тайм-аут») не введет какой-либо символ1, то автосекретарь выполнит действие, указанное в пункте №4. Введенные абонентом символы (исключая завершающий символ, если использован этот тип ввода), автосекретарь запоминает в переменной, имя которой указывается в соответствующем поле.

После того как абонент с помощью телефона введет символы, автосекретарь сравнит их со значениями, указанными в колонке «Значения» таблицы, находящейся в пункте №4. В поле «Количество значений» пользователь, разрабатывающий голосовое меню, определяет, сколько действий могут быть выполнены автосекретарем. В колонке «Действие» таблицы из всплывающего списка пользователь выбирает действие, которое будет выполнено автосекретарем, если абонент введет символы, совпадающие со значением из соответствующей колонки. В колонке «Примечание» можно занести пояснения к указанному действию и значению. Эта информация является необязательной и используется только для повышения информативности разрабатываемого голосового меню.

Если абонент ввел символы, которых нет среди значений таблицы, то автосекретарь выполнит действие, выбранное из всплывающего списка, находящегося сразу после таблицы (поле «если Абонент ввел значение, которого нет среди перечисленных выше»).

Действие, указанное в поле «если вышло время ожидания ввода (тайм-аут)», выполнится, если абонент за указанное в пункте №3 время не введет какой-либо символ.

Смотрите также:

Типы голосового меню
Дерево меню
Действия

Прим. 1. Это время распространяется на каждый символ в отдельности. Т.е. программа-автосекретарь будет ждать ввода очередного символа в течение времени «тайм-аут».


Общее меню

Общее меню отличается от главного только тем, что не имеет настройки числа гудков. Поэтому меню данного типа не может быть первым в алгоритме программы-автосекретаря, и всегда будет находится на втором или более низком уровне в иерархии дерева меню. Общее меню может неограниченное число раз вставляться в голосовое меню.

В упрощенном виде ход выполнения алгоритма общего меню выглядит следующим образом:

  1. При входе в меню произнести в телефонную линию звуковые данные.
  2. Ожидать ввод абонента.
  3. Выполнить действие (набрать номер, перейти в меню и др.) в зависимости от того, что ввел абонент.

Описание пунктов №1-3 общего меню совпадает с аналогичными пунктами в главном меню.


Меню «Голосовая почта – Запись»

Этот тип меню используется для сохранения голосовых сообщений (ГС).

В упрощенном виде ход выполнения алгоритма меню записи ГС выглядит следующим образом:

  1. При входе в меню произнести в телефонную линию фразу типа «Сейчас мы не можем ответить, оставьте сообщение после звукового сигнала» и записать ГС для пользователя.
  2. После записи ГС произнести возможные действия над сообщением:
    • прослушать сообщение снова – нажмите «1»
    • переписать сообщение – нажмите «2»
    • удалить сообщение и вернуться в предыдущее меню – нажмите «3»
  3. Ожидать ввод абонента.
  4. Выполнить действие в зависимости от того, что ввел абонент:
    • прослушать ГС
    • перезаписать ГС
    • удалить ГС и вернуться в предыдущее меню

В пункте №1 этого типа меню кроме аудиофайла также необходимо указать имя пользователя, для которого будет оставлено сообщение. Голосовые сообщения могут быть сохранены только для тех, кто зарегистрирован в системе «Автосекретарь» как пользователь. Имя пользователя выбирается из всплывающего списка.

Если в алгоритме программы-автосекретаря в любом из меню есть действие «Набрать номер», то в списке пользователей также появится переменная «%@VarLogin%». При выборе из всплывающего списка этой переменной сообщение будет сохранено для пользователя, логин которого содержится в этой переменной. Значение этой переменной определяется в одном из параметров действия «Набрать номер».

Пункт №2 уже содержит имя звукового файла. При желании пользователь может задать свой аудиофайл.

Описание пункта №3 кроме поля, определяющего имя переменной, совпадает с описанием аналогичного пункта главного меню.

В пункте №4 предопределено количество значений и перечень действий. Параметр «количество значений» может принимать значение «3» и более. Первые три действия в таблице изменять нельзя, можно лишь изменять значение и примечание.


Меню «Голосовая почта – Прослушать (уровень 1)»

Прослушивание сохраненных голосовых сообщений через телефон реализовано с помощью трехуровневого меню. Меню первого уровня описывается в данном разделе. Оно предназначено для ввода номера ящика голосовой почты.

В упрощенном виде ход выполнения алгоритма этого меню выглядит следующим образом:

  1. При входе в меню произнести в телефонную линию фразу типа «Введите номер ящика голосовой почты».
  2. Ожидать ввода номера ящика. Если ящик с введенным номером не найден, то произнести в телефонную линию фразу типа «Ящик голосовой почты с таким номером не найден» и вернуться к шагу 1.
  3. Перейти в меню «Голосовая почта – Прослушать (уровень 2)».

В пункте №1 указаны аудиофайлы с заранее подготовленными фразами. При желании пользователь может использовать свои собственные аудиофайлы.

Пункт №2 содержит предопределенный тип ввода. Пользователь может изменять только завершающий символ и время «тайм-аут».

Таблица из пункта №3 в данном типе меню не используется. Пользователь может изменять только действие в случае истечения времени «тайм-аут».

После ввода и успешной проверки номера ящика голосовой почты программа-автосекретарь автоматически переходит в меню «Голосовая почта – Прослушать (уровень 2)».


Меню «Голосовая почта – Прослушать (уровень 2)»

Это меню предназначено для ввода пароля и управления ящиком голосовой почты. Находясь в этом меню, после успешного ввода пароля абонент может удалить ГС (все или только прослушанные) или войти в меню прослушивания (уровень 3).

В упрощенном виде ход выполнения алгоритма этого меню выглядит следующим образом:

  1. При входе в меню произнести в телефонную линию фразу типа «Введите пароль».
  2. Ожидать ввода пароля. Если введен неправильный пароль, то произнести в телефонную линию фразу типа «Набран неверный пароль» и вернуться к шагу 1.
  3. После успешного ввода пароля произнести возможные действия над ящиком голосовой почты
    • прослушать сообщения – нажмите «1»
    • удалить все сообщения – нажмите «2»
    • удалить прослушанные сообщения – нажмите «3»
    • вернуться в предыдущее меню – нажмите #
  4. Ожидать ввод абонента.
  5. Выполнить действие в зависимости от того, что ввел абонент:
    • перейти в меню «Голосовая почта – Прослушать (уровень 3)»
    • удалить все сообщения
    • удалить прослушанные сообщения
    • вернуться в предыдущее меню

В пункте №1 указаны аудиофайлы с заранее подготовленными фразами. При желании пользователь может использовать свои собственные аудиофайлы.

Пункт №2 содержит предопределенный тип ввода. Пользователь может изменять только завершающий символ и время «тайм-аут».

В пункте №3 указан заранее подготовленный аудиофайл. Если нужно, пользователь может использовать собственную фразу.

Описание пункта №4 кроме поля, определяющего имя переменной, совпадает с описанием аналогичного пункта главного меню.

В пункте №5 предопределено количество значений и перечень действий. Параметр «количество значений» может принимать значение «4» и более. Первые четыре действия в таблице изменять нельзя, можно лишь изменять значение и примечание.


Меню «Голосовая почта – Прослушать (уровень 3)»

Это меню используется для прослушивания отдельных голосовых сообщений, содержащихся в ящике, определенном в меню «Голосовая почта – Прослушать» уровня 1 и 2.

В упрощенном виде ход выполнения алгоритма этого меню выглядит следующим образом:

  1. При входе в меню выполнить:
    1. Произнести возможные действия во время прослушивания ГС:
      1. на 5 сек. назад –нажмите «7»
      2. на 5 сек. вперед – нажмите «9»
      3. приостановить/продолжить прослушивание – нажмите *
      4. завершить прослушивание – нажмите #
    2. проиграть в телефонную линию ГС
    3. произнести дату и время записи ГС1
    4. произнести возможные действия по перемещению между ГС:
      1. прослушать сообщение снова – нажмите «1»
      2. прослушать предыдущее сообщение – нажмите «4»
      3. прослушать следующее сообщение – нажмите «6»
      4. удалить сообщение – нажмите «5»
      5. вернуться в предыдущее меню – нажмите #
  2. Ожидать ввод абонента.
  3. Выполнить действие в зависимости от того, что ввел абонент:
    1. повторить ГС (перейти к шагу 1.2)
    2. прослушать предыдущее ГС
    3. прослушать следующее ГС. Если абонент прослушал все сообщения, то произнести фразу типа «Достигнут конец списка сообщений» и перейти к шагу 1.4
    4. удалить прослушанное ГС. Если после удаления ящик окажется пустым, то произнести фразу типа «Ящик голосовой почты пуст» и вернуться в предыдущее меню
    5. вернуться в предыдущее меню

В пункте №1 указаны аудиофайлы с заранее подготовленными фразами. При желании пользователь может использовать свои собственные аудиофайлы. Также в этом пункте имеется настройка, определяющая, когда произносить дату и время записи ГС: перед прослушиванием, после него или вообще не произносить. Также эта настройка определяет формат произносимой даты. Она вызывается нажатием на кнопку «Установить», находящейся напротив текста «Произнести дату и время записи сообщения в формате».

Описание пункта №2 кроме поля, определяющего имя переменной, совпадает с описанием аналогичного пункта главного меню.

В пункте №3 предопределено количество значений и перечень действий. Параметр «количество значений» может принимать значение «5» и более. Первые пять действий в таблице изменять нельзя, можно лишь изменять значение и примечание.

Смотрите также:

Типы голосового меню
Дерево меню
Действия
Голосовая почта

Прим. 1. В этом меню имеется настройка, которая указывает, когда произносить дату и время записи ГС: перед прослушиванием ГС, после него или вообще не произносить.


Действия

Программа-автосекретарь в ответ на введенные абонентом символы выполняет различные действия. Их перечень зависит от типа меню, в котором они устанавливаются.

Действия «Перейти в меню», «Набрать номер», «Вызвать подпрограмму» имеют параметры, которые определяются в отдельном окне. Это окно появляется сразу после указания во всплывающем списке одной из этих команд.

Список и описание действий

  • действие «Перейти в меню...»
    • Параметр: имя меню.
    • Описание: выполняет переход в меню, имя которого указано в параметре. Меню выбирается из всплывающего списка, содержащего имена только «дочерних» меню.
    • Используется в типах меню: главное меню, общее меню, меню прослушивания ГС уровня 2.

  • действие «На уровень вверх»
    • Описание: выполняет переход в предыдущее меню (в «родительское» меню).
    • Используется в типах меню: общее меню, меню записи ГС, меню прослушивания ГС уровней 1, 2 и 3.

  • действие «На первый уровень»
    • Описание: выполняет переход в главное меню.
    • Используется в типах меню: общее меню, меню записи ГС, меню прослушивания ГС уровней 1, 2 и 3.

  • действие «Прослушать снова»
    • Описание: программа-автосекретарь переходит к тому месту алгоритма в текущем меню, в котором проигрывается аудиофайл.
    • Используется в типах меню: все.

  • действие «Набрать номер...»
    • Параметры: номер телефона, логин пользователя, контроль, имя меню 1, имя меню 2, тайм-аут.
    • Описание: выполняет набор телефонного номера. Использование в номере символа «F» аналогично нажатию на телефонном аппарате кнопки «Flash». Если параметр «Контроль» определен как «НЕТ», то после набора номера автосекретарь положит трубку и перейдет в начало алгоритма. Если «Контроль» равен «ЕСТЬ», то автосекретарь будет ожидать ответ вызываемого абонента в течение времени «тайм-аут». В этом случае возможны три варианта: абонент занят - выполнится переход в меню 1, абонент не отвечает (вышло время «тайм-аут») - выполнится переход в меню 2, абонент ответил - автосекретарь положит трубку и перейдет в начало алгоритма. Меню выбираются из всплывающего списка, в котором содержатся только «дочерние» меню. В меню 1 и 2 можно вставить меню для записи ГС. В этом случае в меню записи ГС укажите в качестве логина переменную «%@VarLogin%», тогда сообщение будет сохранено для пользователя, логин которого указан в параметре данного действия.
    • Используется в типах меню: главное меню, общее меню.

  • действие «Завершить разговор»
    • Описание: программа-автосекретарь «кладет» трубку и переходит в начало алгоритма
    • Используется в типах меню: все.

  • действие «Вызвать подпрограмму...»
    • Параметр: имя подпрограммы.
    • Описание: выполняет алгоритм указанной в параметре подпрограммы. Подпрограмма выбирается из всплывающего списка параметра. Создание подпрограмм осуществляется с помощью Конструктора.
    • Используется в типах меню: все.

  • действие «Повторить ввод»
    • Описание: выполняет переход на то место в алгоритме текущего меню, в котором ожидается ввод абонента.
    • Используется в типах меню: все.

  • действие «Прослушать ГС»
    • Описание: выполняет прослушивание голосового сообщения, после того как абонент сохранил его для пользователя.
    • Используется в типах меню: меню записи ГС.

  • действие «Перезаписать ГС»
    • Описание: выполняет перезапись только что сохраненного голосового сообщения.
    • Используется в типах меню: меню записи ГС.

  • действие «Удалить ГС»
    • Описание: удаляет голосовое сообщение.
    • Используется в типах меню: меню записи ГС, меню прослушивания ГС уровня 3.

  • действие «Удалить все сообщения»
    • Описание: удаляет все сообщения, находящиеся в ящике голосовой почты.
    • Используется в типах меню: меню прослушивания ГС уровня 2.

  • действие «Удалить прослушанные сообщения»
    • Описание: удаляет только прослушанные сообщения ящика голосовой почты.
    • Используется в типах меню: меню прослушивания ГС уровня 2.

  • действие «Повторить сообщение»
    • Описание: выполняет повторное прослушивание голосового сообщения.
    • Используется в типах меню: меню прослушивания ГС уровня 3.

  • действие «Предыдущее сообщение»
    • Описание: выполняет прослушивание предыдущего сообщения.
    • Используется в типах меню: меню прослушивания ГС уровня 3.

  • действие «Следующее сообщение»
    • Описание: выполняет прослушивание следующего сообщения
    • Используется в типах меню: меню прослушивания ГС уровня 3.


Конструктор

Конструктор предназначен для составления алгоритма (программы-автосекретаря). Он создает графическое представление алгоритма, наглядно показывающее, как будут выполняться команды программы. Инструментарий Конструктора очень гибок, что дает пользователю возможность создавать практически любой алгоритм в рамках имеющихся команд.

С помощью Конструктора можно не только разрабатывать алгоритм программы-автосекретаря, но также составлять подпрограммы, которые могут быть использованы в Дереве меню как часть общего алгоритма.

В Конструкторе можно выделить несколько рабочих областей: 1 –панель инструментов, 2 – панель команд, 3 – поле алгоритма, 4 – свойства команды, 5 – описание команды и ее параметров.

Алгоритм создается следующим образом.
Сначала необходимо выбрать команду на панели команд, потом в поле алгоритма указать на связь (голубая линия между командами), куда необходимо вставить новую команду, и, если нужно, настроить параметры команды в области свойства команды (установка команды «Перейти к метке» имеет некоторые отличия, подробности см. в описании команды в разделе «Список и описание команд алгоритма»).

Отмена текущего действия осуществляется нажатием на панели команд кнопки «Отменить действие» [image], удаление команды производится после нажатия кнопки «Удалить команду» [image].

Многие команды алгоритма имеют различные параметры. Они настраиваются в области свойства команды двумя способами: с использованием всплывающего списка и редактируемого поля. Для того чтобы введенное значение в редактируемом поле сохранилось в алгоритме, необходимо нажать на клавиатуре клавишу «Enter». Если этого не сделать, то введенное значение будет утеряно, и содержимое параметра не будет изменено.

После того как алгоритм был разработан, его необходимо сохранить в базе данных. На панели инструментов необходимо нажать кнопку «Сохранить алгоритм в базе данных» [image], указать тип алгоритма (программа или подпрограмма) и его имя. Перед сохранением всегда осуществляется проверка алгоритма на ошибки.

Конструктор позволяет изменять алгоритм, который уже был сохранен в базе данных. Для этого необходимо загрузить его в Конструктор. На панели инструментов нажмите на кнопку «Загрузить алгоритм из базы данных» [image], выберите имя из списка программ или подпрограмм.

При конструировании алгоритма можно периодически проверять его на наличие ошибок, нажимая кнопку «Проверить алгоритм на ошибки» [image].

Удаление существующего алгоритма выполняется кнопкой «Создать новый алгоритм» [image], при этом алгоритм, находящийся в БД, не изменяется.


Список и описание команд алгоритма

Вкладка «События»
Команды этой вкладки ожидают некоторое событие и при его наступлении передают управление следующей команде.

Ожидать дозвон
Параметры: количество дозвонов N.
Описание: команда ожидает входящие звонки и после N дозвонов (гудков) снимает трубку и передает управление следующей команде. Число N не должно быть отрицательным.

Ждать действия абонента
Параметры: имя переменной Var, время ожидания N.
Описание: команда ожидает действие вызываемого абонента. Возможны следующие варианты: вызываемый абонент взял трубку – переменная Var примет значение «0», абонент занят – Var будет равна «1», вышло время ожидания – Var будет содержать «2». Имя переменной Var может содержать английские и русские буквы, цифры и знак подчеркивания «_», но оно не должно начинаться с цифры. Время ожидания N измеряется в секундах, и оно не должно быть отрицательным. Эта команда используется только после выполнения команды Набрать номер.

Ввод символа(ов) до завершающего символа
Параметры: имя переменной Var, символ завершения, время ожидания N, значение по умолчанию Val.
Описание: команда ожидает ввода символов (DTFM сигналов) абонентом. Ввод прекращается нажатием символа завершения, который выбирается из всплывающего списка. Результат ввода (исключая символ завершения) заносится в переменную Var. В качестве символа завершения можно использовать цифры от «0» до «9», буквы «A», «B», «C», «D» и символы «*», «#». Если за время N абонент не введет ни одного символа, то команда завершится, и переменная Var примет значение по умолчанию Val. Отсчет времени ожидания начинается после каждого нажатия символа. Параметр N измеряется в секундах, и он не должен быть отрицательным.

Ввод заданного числа символов
Параметры: имя переменной Var, количество символов N1, время ожидания N2, значение по умолчанию Val.
Описание: команда ожидает ввода символов (DTFM сигналов) абонентом. Ввод завершится после того, как абонент введет определенное количество символов. Результат ввода содержится в переменной Var. Количество символов N1 должно быть больше ноля. Если за время N2 абонент не введет ни одного символа, то команда завершится, и переменная Var примет значение по умолчанию Val. Отсчет времени ожидания начинается после каждого нажатия символа. Параметр N2 измеряется в секундах, и он не должен быть отрицательным.

Вкладка «Действия»
Команды этой вкладки выполняют конкретные действия, вызывая внутренние команды устройства SpRecord.

Набрать номер
Параметры: номер телефона Num.
Описание: команда набирает номер телефона Num. Номер может содержать следующие символы: «0»..«9», «A», «B», «C», «D», «*», «#», «F» (кнопка Flash). Также внутри номера можно включать переменные, разделенные символом «%» («процент»). Например, пусть параметр Num содержит «123 %Var1% 1321». При наборе номер будет преобразован следующим образом: «123» плюс значение переменной Var1 (например «102») плюс «1321», т.е. в результате номер будет содержать «1231021321». Пробелы игнорируются. С помощью контекстного меню параметра можно вставить существующие переменные в набираемый номер.

Взять трубку
Параметры: нет.
Описание: команда замыкает шлейф телефонной линии (поднимает телефонную трубку).

Положить трубку

Параметры: нет.
Описание: команда размыкает шлейф телефонной линии (кладет телефонную трубку).

Проиграть аудиофайл
Параметры: имя файла File.
Описание: проиграть аудиофайл в телефонную линию. Имя (вместе с путем, если он есть) файла должно быть меньше 100 символов. Аудиофайл должен иметь следующий формат: несжатый PCM (как правило, с расширением «WAV»), частота 11,025 кГц, 8 бит, моно. Также есть возможность вызова Звукового редактора через контекстное меню параметра, определяющего аудиофайл. Если параметр содержит имя файла, то редактор откроет этот файл. При сохранении аудиофайла в редакторе (пункт меню «Сохранить как») его имя будет автоматически присвоено параметру, из которого был вызван редактор. Звуковые данные можно передавать в телефонную линию только при поднятой трубке телефона (см. команду Взять трубку). Если во время проигрывания абонент нажал кнопку телефона, то проигрывание немедленно прекращается, а введенный символ запоминается, чтобы использовать его в командах ожидания ввода.

Получить определившийся номер
Параметры: имя переменной Var.
Описание: команда возвращает в переменной Var номер звонящего абонента, если он определился АОНом. Если номер не был определен к моменту вызова команды, то переменная будет содержать «0».

Вкладка «Служебные»
В эту группу входят команды, реализация которых не связана с вызовом внутренних команд устройства SpRecord.

Условие «Если равно»
Параметры: имя переменной, значение Val.
Описание: команда сравнивает переменную со значением Val. Если они равны, то будут выполнятся команды в ветке «Да», иначе – в ветке «Нет» (см. рис. ниже). Переменная выбирается из всплывающего списка.

Выход из программы
Параметры: нет.
Описание: команда завершает работу алгоритма (программы-автосекретаря).

Метка
Параметры: имя метки Lab.
Описание: метка устанавливается в то место алгоритма, в которое планируется осуществить переход (см. команду Перейти к метке). Имя метки Lab может содержать английские и русские буквы, цифры и знак подчеркивания «_», но оно не должно начинаться с цифры.

Перейти к метке
Параметры: имя метки.
Описание: команда осуществляет переход в алгоритме на указанную метку. Метка выбирается из всплывающего списка. При выборе этой команды в панели команд вначале необходимо указать в алгоритме метку, на которую планируется осуществить переход, а после этого установить команду перехода в алгоритме. Таким образом перед использованием этой команды алгоритм уже должен содержать необходимую метку.

Пауза
Параметры: задержка N.
Описание: команда выполняет задержку на N миллисекунд. Напомню, что в 1 секунде содержится 1000 миллисекунд (мсек.). Задержка N не должна быть меньше ноля.

Перейти в начало алгоритма
Параметры: нет.
Описание: команда переходит в начало алгоритма и выполняет первую команду.

Зафиксировать событие
Параметры: тип события, текст Val.
Описание: команда записывает сообщение с текстом Val в журнал событий (см. раздел «Журнал событий»). Тип события выбирается пользователем из всплывающего списка. Текст может содержать любые символы и переменные, заключенные в «%» («процент»). Это команда используется при формировании отчетов для фиксации различных событий (см. раздел «Отчеты»).

Создать переменную
Параметры: имя переменной Var.
Описание: команда создает переменную с именем Var и делает ее доступной другим командам алгоритма. Если переменная с именем Var уже существует, то команда сразу завершается и передает управление следующей команде.

Установить значение переменной
Параметры: имя переменной, значение Val.
Описание: команда присваивает переменной значение Val. Переменная выбирается из всплывающего списка.

Увеличить значение переменной на 1
Параметры: имя переменной.
Описание: команда увеличивает значение переменной на 1. Переменная выбирается из всплывающего списка.

Вкладка «Голосовая почта»
В эту группу входят команды, выполняющие операции над сообщениями и ящиками голосовой почты.

Записать голосовое сообщение
Параметры: логин пользователя, имя файла File.
Описание: команда проигрывает аудиофайл в телефонную линию, выдает короткий гудок и затем записывает голосовое сообщение для указанного пользователя. Сообщение можно оставить только для зарегистрированного в системе пользователя, который выбирается из всплывающего списка (см. раздел «Администрирование пользователей»). В качестве пользователя можно указать переменную, заключенную в «%» («процент»). Описание параметра «имя файла» дано в команде Проиграть аудиофайл. Максимальная длина одного голосового сообщения определяется настройками пользователя (см. раздел «Администрирование пользователей»). При нажатии абонентом любой кнопки прекращается запись голосового сообщения.

Получить ID последнего голосового сообщения
Параметры: имя переменной Var.
Описание: команда заносит в переменную Var идентификатор голосового сообщения, который был записан с помощью команды Записать голосовое сообщение. Если в алгоритме до команды «Получить ID последнего голосового сообщения» уже несколько раз записывалось голосовое сообщение, то возвращается идентификатор последнего записанного сообщения. Если Var содержит «0», то идентификатор не определен. После вызова этой команды при прослушивании сообщения с помощью команды Прослушать голосовое сообщение признак «Сообщение прослушано» изменяться не будет. Изменение этого признака при прослушивании сообщения будет происходить после вызова команды Проверить пароль ящика голосовой почты.

Удалить голосовое сообщение
Параметры: имя переменной.
Описание: команда удаляет из системы голосовое сообщение, идентификатор которого находится в переменной. Переменная выбирается из всплывающего списка.

Прослушать голосовое сообщение
Параметры: имя переменной, формат даты N.
Описание: команда воспроизводит в телефонную линию записанное в системе голосовое сообщение, идентификатор которого находится в переменной. Переменная выбирается из всплывающего списка. При выполнении этой команды голосовое сообщения отмечается как прослушанное (исключения см. в команде Получить ID последнего голосового сообщения. При воспроизведении «Автосекретарь» в зависимости от формата даты N произносит дату и время записи сообщения. Формат даты определяется комбинацией следующих значений: 1 - день недели, 2 - число, 4 - месяц, 8 - часы, 16 - минуты, 32 - год, 64 - произнести дату в конце сообщения. Например, если N будет равно 102 (т.е. 2 + 4 + 32 + 64), то автосекретарь произнесет число, месяц и год записи сообщения после воспроизведения голосового сообщения. А если N будет равно 25 (т.е. 1 + 8 + 16), то автосекретарь произнесет день недели, час и минуту записи сообщения перед воспроизведением голосового сообщения. Во время прослушивания сообщения можно управлять воспроизведением: кнопка «7» - перемотка назад на 5 сек., «9» - перемотка вперед на 5 сек., «*» - приостановить/продолжить, «#» - завершить прослушивание, выйти из команды.

Проверить, существует ли ящик голосовой почты
Параметры: имя переменной Var1, имя переменной Var2.
Описание: команда проверяет, существует ли ящик голосовой почты с номером, содержащимся в переменной Var1. Если ящик с таким номером существует, то переменная Var2 будет содержать «1», иначе - «0». Переменная Var1 выбирается из всплывающего списка.

Проверить пароль ящика голосовой почты
Параметры: имя переменной Var1, имя переменной Var2, имя переменной Var3.
Описание: команда проверяет пароль (переменная Var2) ящика с номером Var1 и возвращает результат в переменной Var3. Если пароль для указанного ящика верный, то Var3 будет содержать «1», если нет, то Var3 примет значение «0». Переменные Var1 и Var2 выбираются из всплывающего списка. Эта команда влияет на признак «Сообщение прослушано» (подробнее см. команды Получить ID последнего голосового сообщения и Прослушать голосовое сообщение).

Удалить все сообщения из ящика
Параметры: имя переменной.
Описание: команда удаляет все голосовые сообщения из ящика с номером, определяемым содержимым переменной. Переменная выбирается из всплывающего списка.

Удалить прослушанные сообщения из ящика
Параметры: имя переменной.
Описание: команда удаляет все прослушанные голосовые сообщения из ящика с номером, определяемым содержимым переменной. Переменная выбирается из всплывающего списка.

Проверить, пустой ли ящик голосовой почты
Параметры: имя переменной Var1, имя переменной Var2
Описание: команда проверяет, есть ли сообщения в ящике с номером Var1. Если сообщения отсутствуют, то переменная Var2 будет равна «0», иначе - «1». Переменная Var1 выбирается из всплывающего списка.

Получить список сообщений ящика голосовой почты
Параметры: имя переменной.
Описание: команда формирует внутренний список идентификаторов всех голосовых сообщений, находящихся в ящике, номер которого определяется переменной. Сообщения в списке расположены по убыванию их даты записи, т.е. в начале списка находятся сообщения, записанные последними. Эта команда необходима для перемещения между сообщениями и должна вызываться всегда перед использованием команд Список пуст или достигнут конец списка, Перейти к предыдущему сообщению в списке, Перейти к следующему сообщению в списке, и Получить ID текущего сообщения в списке. Имя переменной выбирается из всплывающего списка.

Список пуст или достигнут конец списка
Параметры: имя переменной Var.
Описание: команда проверяет состояние списка сообщений, сформированного командой Получить список сообщений ящика голосовой почты. Результат проверки находится в переменной Var: «0» - список пуст, «1» - достигнут конец списка, во всех остальных случаях «2». Она проверяет внутренний флаг, сигнализирующий о достижении конца списка, записывает результат в переменной Var и сбрасывает этот флаг в состояние «Конец списка не достигнут» (см. команду Перейти к следующему сообщению в списке). Эта команда всегда должна вызываться после выполнения команды Получить список сообщений ящика голосовой почты.

Перейти к предыдущему сообщению в списке
Параметры: нет.
Описание: команда перемещает текущий указатель в списке сообщений на предыдущую позицию. Если перед выполнением команды указатель уже был на первой позиции в списке, то команда не выполнит никаких действий. Эта команда всегда должна вызываться после выполнения команды Получить список сообщений ящика голосовой почты.

Перейти к следующему сообщению в списке
Параметры: нет.
Описание: команда перемещает текущий указатель в списке сообщений на следующую позицию. Если перед выполнением команды указатель уже был на последней позиции в списке, то команда установит внутренний флаг в состояние «Достигнут конец списка» и не выполнит никаких действий (см. команду Список пуст или достигнут конец списка). Эта команда всегда должна вызываться после выполнения команды Получить список сообщений ящика голосовой почты.

Получить ID текущего сообщения в списке
Параметры: имя переменной Var.
Описание: команда заносит в переменную Var идентификатор сообщения, на который указывает текущий указатель в списке сообщений. Если Var равен «0», то идентификатор неопределен. Эта команда всегда должна вызываться после выполнения команды Получить список сообщений ящика голосовой почты.

Произнести количество сообщений
Параметры: имя переменной.
Описание: команда произносит в телефонную линию количество всех сообщений, находящихся в ящике голосовой почты, а затем – количество прослушанных сообщений. Номер ящика определяется переменной, которая выбирается из всплывающего списка.


Сервер

Задача «Сервер» позволяет через клиент «Автосекретаря» управлять настройками сервера.

Изменение настроек сервера имеет свои особенности. После того как пользователь изменил настройки, необходимо нажать на кнопку «Сохранить», чтобы сделанные изменения были сохранены на сервере.

Сохраненные настройки вступают в силу только после перезагрузки компьютера сервера.

Тип источника данных

В этой настройке пользователь выбирает из всплывающего списка, где будут храниться данные: в базе данных MS SQL Server или в отдельных таблицах формата Parodox 7. Поскольку изменения настроек начинают действовать не сразу, то под всплывающим списком в поле «сейчас» отображается текущий тип источника данных.

TCP/IP порт

В этой настройке пользователь устанавливает, какой порт будет использоваться при обмене данными между сервером и клиентами по TCP/IP протоколу. Это может понадобиться, например, если порт, устанавливаемый по умолчанию в «Автосекретаре», уже используется другой программой. Номер порта должен быть в диапазоне 1001 – 65535.

Настройка SQL сервера

Здесь пользователь определяет параметры доступа к SQL серверу (имя сервера, логин и пароль для входа на сервер) и имя базы данных, в которой хранится используемая «Автосекретарем» информация. Параметр «Тайм-аут соединения» определяет максимальное время, в течение которого сервер «Автосекретаря» пытается подключиться к SQL серверу. По истечении этого времени и безуспешного подключения сервер «Автосекретаря» прекратит свое выполнение.

Задачи

После установки сервера «Автосекретаря» по умолчанию используются локальные таблицы для хранения данных1. Если необходимо переключиться на использование SQL сервера для хранения данных «Автосекретаря», то потребуется предварительно выполнить задачи на стороне сервера: создать базу данных на SQL сервере, протестировать соединение с SQL сервером.

Выполнение первой задачи может потребоваться в следующих случаях:

  • если в SQL сервере нет базы данных «Автосекретаря». В этом случае выберите из всплывающего списка задачу «Создать БД на SQL сервере», в поле «Параметры» введите имя новой базы данных. Далее заполните поля в настройках SQL сервера (в поле «Имя БД» напишите «master»). Сохраните изменения настроек и нажмите кнопку «Выполнить». При успешном выполнении задачи программа выведет соответствующее сообщение.
  • если «Автосекретарь» уже использует базу данных SQL сервера, и требуется создать новую. Выберите из всплывающего списка задачу «Создать БД на SQL сервере», в поле «Параметры» введите имя новой базы данных и нажмите кнопку «Выполнить». При успешном выполнении задачи программа выведет соответствующее сообщение.

После того как источник данных был изменен на использование SQL сервера, возможно, потребуется выполнить тестирование соединения. В этом случае введите необходимые данные в поля «Настройка SQL сервера», сохраните их, выберите задачу «Тест соединения с SQL сервером» и нажмите кнопку «Выполнить». Сервер «Автосекретаря», используя сохраненные настройки SQL сервера, протестирует соединение с ним и результат теста отправит клиенту. Клиент в свою очередь выдаст сообщение с результатом теста соединения.

Смотрите также:

Вход в систему (авторизация)

Прим. 1. Во время инсталляции сервера «Автосекретаря» возможно изменение настроек по умолчанию. В этом случае после установки сервера будет использоваться источник данных, определенный во время инсталляции.


Отчеты

Задача «Отчеты» дает возможность пользователю получать информацию о том, какие события произошли во время сеанса «разговора» звонящего абонента с программой-автосекретарем.

Параметры фильтра

Для формирования отчета пользователь должен указать в запросе период, в течение которого фиксировались события, отрезок времени (шаг), на который делится период, события, которые нужно вывести в отчете, и канал телефонной линии.

Пользователь может выбрать следующие события:

  • входящие звонки;
  • неотвеченные вызовы;
  • оператор взял трубку;
  • автосекретарь взял трубку;
  • вызванные отделы (т. е. набранные программой-автосекретарем внутренние номера);
  • вызванные уровни меню (фиксируется вход звонящего абонента в какое-либо меню программы-автосекретаря);
  • исходящие звонки (фиксируется после команды набора номера, когда ожидается ответ вызываемого абонента);
  • вызываемый абонент ответил на вызов (фиксируется, если вызываемый абонент взял трубку);
  • вызываемый абонент не ответил на вызов (фиксируется, если линия вызываемого абонента занята или вышло время ожидания ответа);
  • ответ вызываемого абонента посредством DTFM набора;
  • соединение с программой записи прервано;
  • событие пользователя (в алгоритме программы-автосекретаря фиксируется команда «Зафиксировать событие»).

При выборе события, канала или нажатии на кнопку «Изменить» программа формирует отчет и отображает его в виде графика или таблицы.

Настройка отображения отчета

Отчет может быть представлен в трех формах:

  • в табличной форме

  • в виде графика из прямоугольников

  • в виде графика из линий

Для некоторых видов событий (например, «Вызванные уровни меню», «Вызванные отделы» и др.) формируется не один отчет, а несколько, в зависимости от количества значений, найденных для этих событий. Например, событие «Вызванные уровни меню» может иметь несколько значений: «Главное меню», «Меню записи голосового сообщения», «Меню вызова оператора» и т.п. В этом случае, чтобы просмотреть отчет, необходимо кроме события еще указать значение из всплывающего списка «Значение».

Обновление данных отчета вызывается нажатием на панели инструментов кнопки «Обновить отчет» [image] или выбором соответствующего пункта в контекстном меню.

Сформированный отчет можно сохранить в файле формата CSV, поддерживаемом MS Excel и OpenOffice Calc. Для сохранения отчета необходимо на панели инструментов нажать кнопку «Сохранить отчет» [image] или в контекстном меню выбрать соответствующий пункт.

Особенности отображения графика

Чтобы отобразить отчет в графическом виде, необходимо выбрать переключатель «Прямоугольник» или «Линия». График может отображаться в плоской или объемной форме (галочка «3D»). Настройка «Показать значения» включает/отключает надписи значений. Также можно изменять количество выборок (шагов), которые одновременно отображаются в графике (поле «Обзор длиной..»). Настройка «Показать график с выборки №» позволяет начало графика перенести на установленную позицию.

Также график можно распечатать на принтере, нажав на панели инструментов кнопку «Печать отчета» [image] или выбрав в контекстном меню пункт «Распечатать».

Смотрите также:

Команда «Зафиксировать событие»


Журнал событий

Задача «Журнал событий» отображает события и сообщения, зафиксированные сервером «Автосекретаря». Благодаря этой задаче пользователь может в реальном времени следить за состоянием сервера и программ-автосекретарей, выполняющихся на каналах. Также журнал событий позволяет обнаруживать причины неполадок и сбоев в работе различных программных модулей сервера.

Информация, содержащаяся в журнале, будет полезна для службы технической поддержки данного программного комплекса, что позволит ей сделать «Автосекретарь» более качественным продуктом.

Журнал событий в основном содержит служебную и специфическую информацию, которая не понадобится рядовым пользователям «Автосекретаря». Поэтому разумно открывать доступ к этой задаче только для пользователей с правами администратора.

Журнал событий имеет фильтр отображения данных. Он вызывается нажатием на панели инструментов кнопки «Задать фильтр» [image] или через контекстное меню выбором одноименного пункта.

В фильтре можно указать период, в течение которого фиксировались события сервером, тип (типы) зафиксированных сообщений и канал (каналы), на котором фиксировались сообщения.

Обновление отображаемых данных в соответствии с выбранными настойками фильтра выполняется нажатием на панели инструментов кнопки «Обновить» [image] или через контекстное меню задачи.

Сформированный список сообщений можно сохранить в файле формата CSV, поддерживаемом MS Excel и OpenOffice Calc. Для этого необходимо на панели инструментов нажать кнопку «Сохранить в файл CSV» [image] или в контекстном меню выбрать соответствующий пункт.


Голосовая почта

«Автосекретарь» имеет возможность сохранять голосовые сообщения для зарегистрированных пользователей. Доступ к этим сообщениям возможен как через телефон, так и через задачу «Голосовая почта» клиента «Автосекретаря».

В зависимости от назначенных прав пользователь может иметь доступ к голосовым сообщениям всех пользователей или только к личным сообщениям (см. раздел «Администрирование пользователей»).

Во время прослушивания сообщений пользователю доступны следующие функции:

  • проиграть сообщение (на панели инструментов или в контекстном меню [image]);
  • пауза при прослушивании (на панели инструментов или в контекстном меню [image]);
  • остановить прослушивание (на панели инструментов или в контекстном меню [image]);
  • изменить громкость;
  • изменить позицию прослушивания в сообщении.

При прослушивании пользователем голосовых сообщений через телефон или клиент «Автосекретаря» проигранное сообщение автоматически помечается как прослушанное.

Удаление сообщения производится нажатием на панели инструментов кнопки «Удалить голосовое сообщение» [image]. Голосовое сообщение удаляется безвозвратно.

Обновление списка сообщений выполняется нажатием на панели инструментов кнопки «Обновить» [image] или через контекстное меню задачи.

Смотрите также:

Администрирование пользователей